Aiuto - Cerca - Utenti - Calendario
Versione completa: Il castello di LB, questo sconosciuto...
OldGamesItalia > (Old)Games > Videogiochi > Ultima Babylon
ILLOCA
Ciao a tutti, ho un problema(one???) non riesco a entrare nel castello di LB a Britain, non c'è piu' il ponte levatoio (e anche i cannoni a essere pignoli).
All'inizio del gioco c'ero passato davanti ed era tutto a posto, pero' ho deciso di tornarci il giorno dopo e ho trovato la situazione sopracitata.
Ho continuato a giocare per diversi giorni e tornando non era cambiato niente.

Gioco con la versione di Exult 1.4
(res 400X300 3Hq)

Se qualche anima pia che incarna la virtu' della pazienza mi da' l'indirizzo mail provo a inviargli i save per dargli un occhiata.
OVVIAMENTE mi deve tornare indietro con l'inventario sistemato a dovere lookaround.gif
The Ancient One
Ciao ILLOCA, che bella sorpresa!
Ormai non ci speravo quasi più! tongue.gif

Provvedo subito a saldare il mio debito: in questa discussione trovi la mappa della miniera di Minoc che ti avevo promesso! n5.gif

Mentre a te non resta che presentarti nel forum "Just Arrived" e lasciare un tuo commento sulla traduzione!
Per il resto siamo qui per qualsiasi dubbio!


CITAZIONE (ILLOCA @ 6 Nov 2007, 08:57) *
Se qualche anima pia che incarna la virtu' della pazienza mi da' l'indirizzo mail provo a inviargli i save per dargli un occhiata.
OVVIAMENTE mi deve tornare indietro con l'inventario sistemato a dovere lookaround.gif

La mia mail ti è arrivata tramite MP del forum.
Però è ancora più semplice se alleghi il salvataggio direttamente qui sul forum.

Mentre cos'è successo al tuo inventario? lookaround.gif

Un saluto e... benvenuto su OldGamesItalia! n5.gif
The Ancient One
shocked.gif

Il ponte levatoio e la staccionata antistante sono spariti!!!! shocked.gif
Questo è veramente strano, perché da anni nessuno segnala bug di oggetti spariti...

Le cose sono due:
- ho è un bug di exult (magari del keyring mod)
- oppure hai cancellato tu quegli oggetti inavvertitamente (con CTRL+D si cancellano permanentemente gli oggetti dal mondo)
Hai idea di cosa sia successo?
Potresti riprodurlo?

In entrambi i casi comunque non c'è una soluzione facile per rimettere il pontelevatoio, se non iniziare una nuova partita.

Però, sperando che il problema sia isolato (e ne sono sicuro), puoi:
- utilizzare il cheat del teletrasporto per entrare nel castello (premi F3 e clicca nel punto in cui vuoi teletrasportarti)
- utilizzare il tappeto volante (quando lo troverai) per entrare nel castello, atterrando sul tetto o nel giardino (se c'è spazio)
- costruirti un ponte con tavole di legno, ma sono difficili da trovare (e non so se il tipo di tavola necessario c'è solo in U7p2)
- costruirti un ponte levatorio con delle casse (ma per questo devi accedere almeno una volta all'interno del castello per fare la seconda metà del ponte).

Mi dispiace, ma più di così non posso aiutarti.
E tu sembri l'unico ad aver avuto questo problema...
Per fortuna non pregiudica il gioco, quindi vai tranquillo!

Resto a disposizione!
-diego
ILLOCA
CITAZIONE (The Ancient One @ 6 Nov 2007, 12:27) *
shocked.gif

Il ponte levatoio e la staccionata antistante sono spariti!!!! shocked.gif
Questo è veramente strano, perché da anni nessuno segnala bug di oggetti spariti...

Le cose sono due:
- o è un bug di exult (magari del keyring mod)
- oppure hai cancellato tu quegli oggetti inavvertitamente (con CTRL+D si cancellano permanentemente gli oggetti dal mondo)
Hai idea di cosa sia successo?
Potresti riprodurlo?

In entrambi i casi comunque non c'è una soluzione facile per rimettere il pontelevatoio, se non iniziare una nuova partita.

Però, sperando che il problema sia isolato (e ne sono sicuro), puoi:
- utilizzare il cheat del teletrasporto per entrare nel castello (premi F3 e clicca nel punto in cui vuoi teletrasportarti)


Preciso che l'unica azione sospetta è stato il dialogo con Zauriel, pero' ho riprovato da un vecchio salvataggio ad andare direttamente da Zauriel e il levatoio è rimasto, quindi non saprei.
Mi sembra strano di aver schiacciato inavvertitamente ctrl+D, anche perchè come hai visto, non solo è sparito il levatoio ma anche i cannoni.
Tu hai provato il teletrasporto con F3 ? Funzia?

CITAZIONE (The Ancient One @ 6 Nov 2007, 12:02) *
Mentre cos'è successo al tuo inventario? lookaround.gif


Chiedevo se qualcuno aveva voglia di mettermelo un po' in ordine biggrin.gif

Ecco i file di salvataggio
L'ultimo è Illoca16 che è gia' davanti al levatoio incriminato

Forse è qua dentro, comunque è sempre "loca16" icon_salut.gif
The Ancient One
CITAZIONE (ILLOCA @ 6 Nov 2007, 13:25) *
Preciso che l'unica azione sospetta è stato il dialogo con Zauriel, pero' ho riprovato da un vecchio salvataggio ad andare direttamente da Zauriel e il levatoio è rimasto, quindi non saprei.
Mi sembra strano di aver schiacciato inavvertitamente ctrl+D, anche perchè come hai visto, non solo è sparito il levatoio ma anche i cannoni.

Immaginavoche non fossi stato tu... E' veramente strano.
Se hai tempo, perché non provi a iniziare brevemente una nuova partita e riparlare con Zauriel.
Magari scopriamo un bug sconosciuto!

CITAZIONE
Tu hai provato il teletrasporto con F3 ? Funzia?

Sì! Vai tranquillo!

CITAZIONE
CITAZIONE (The Ancient One @ 6 Nov 2007, 12:02) *
Mentre cos'è successo al tuo inventario? lookaround.gif

Chiedevo se qualcuno aveva voglia di mettermelo un po' in ordine biggrin.gif

smilies3.gif smilies3.gif
Farebbe comodo anche a me...
ILLOCA
CITAZIONE (The Ancient One @ 6 Nov 2007, 15:52) *
Se hai tempo, perché non provi a iniziare brevemente una nuova partita e riparlare con Zauriel.
Magari scopriamo un bug sconosciuto!


Ho gia' provato ed è tutto a posto, non so' proprio cosa sia accaduto...
Comunque stasera provo con F3...
The Ancient One
CITAZIONE (ILLOCA @ 6 Nov 2007, 16:00) *
CITAZIONE (The Ancient One @ 6 Nov 2007, 15:52) *
Se hai tempo, perché non provi a iniziare brevemente una nuova partita e riparlare con Zauriel.
Magari scopriamo un bug sconosciuto!


Ho gia' provato ed è tutto a posto, non so' proprio cosa sia accaduto...

Misteri!
Del resto Exult, per essere un programma amatoriale, ha fin troppi pochi bug.
Presumo che qualche piccolo inconveniente sia inevitabile.

L'importante è che non si tratti di bug che rovinano la partita.

Se scopri qualcosa, tienici aggiornati!
ILLOCA
Ieri ho passato mezzora nel castello di LB a tirar leve per trovare il magazzino segreto, anche leggendo la soluzione da' per scontato che sia facile e questo mi preoccupa...
The Ancient One
CITAZIONE (ILLOCA @ 8 Nov 2007, 11:47) *
Ieri ho passato mezzora nel castello di LB a tirar leve per trovare il magazzino segreto, anche leggendo la soluzione da' per scontato che sia facile e questo mi preoccupa...

Ehhe... onestamente io non l'ho trovato difficile... Però considera che vengo da anni di Dungeon Master e Eye of the Beholder... smilies3.gif
Quando dici "magazzino segreto" ti riferisci a quello sul tetto? Perché in quel caso è facilissimo da trovare!

Comunque, come forse hai letto, stiamo aggiornando la soluzione.
Quindi, se vuoi riscrivere questo pezzo per renderlo più chiaro, sarà poi un piacere inserirlo nella nuova versione!
Thurlik
CITAZIONE (The Ancient One @ 8 Nov 2007, 14:09) *
Quindi, se vuoi riscrivere questo pezzo per renderlo più chiaro, sarà poi un piacere inserirlo nella nuova versione!

Ciao ILLOCA! Siiii, ti prego!.... Così mi allegerisci il lavoro! angelo.gif
ILLOCA
CITAZIONE (The Ancient One @ 8 Nov 2007, 13:09) *
CITAZIONE (ILLOCA @ 8 Nov 2007, 11:47) *
Ieri ho passato mezzora nel castello di LB a tirar leve per trovare il magazzino segreto, anche leggendo la soluzione da' per scontato che sia facile e questo mi preoccupa...

Ehhe... onestamente io non l'ho trovato difficile... Però considera che vengo da anni di Dungeon Master e Eye of the Beholder... smilies3.gif
Quando dici "magazzino segreto" ti riferisci a quello sul tetto? Perché in quel caso è facilissimo da trovare!

Comunque, come forse hai letto, stiamo aggiornando la soluzione.
Quindi, se vuoi riscrivere questo pezzo per renderlo più chiaro, sarà poi un piacere inserirlo nella nuova versione!


Premesso che ho passato le notti sui giochi sopracitati, potrei anche scrivere come accedere al magazzino, il problema è che non ci riesco io biggrin.gif
Ho provato a tirare tutte e 5 le leve con combinazioni differenti (forse tutte tranne una) ma non succede niente se non spostare qualche porta a muro...
The Ancient One
CITAZIONE
Premesso che ho passato le notti sui giochi sopracitati,

Indimenticabili! smokin.gif

CITAZIONE (ILLOCA @ 9 Nov 2007, 10:58) *
Premesso che ho passato le notti sui giochi sopracitati, potrei anche scrivere come accedere al magazzino, il problema è che non ci riesco io biggrin.gif
Ho provato a tirare tutte e 5 le leve con combinazioni differenti (forse tutte tranne una) ma non succede niente se non spostare qualche porta a muro...

Carissimo, perdonami, ma non capisco a quale magazzino ti riferisci!
Screenshot o savegame!

n5.gif
ILLOCA
CITAZIONE (The Ancient One @ 9 Nov 2007, 13:06) *
Carissimo, perdonami, ma non capisco a quale magazzino ti riferisci!


Scegli Tu quale, perchè proprio non riesco ad accedere a nessuno dei 2 n7.gif
Thurlik
Per aprire il magazzino a Nord/Ovest bisogna usare la chiave che è nel comodino nello studio di Lord British


Per aprire il magazzino di Nord/Est bisogna azionare la leva dietro al barile nell'angolo Nord/Est del corridoio che circonda il castello


bananab.gif
The Ancient One
La soluzione 2.0 di Thurlik si preannuncia moooolto interessante! roargh.gif
ILLOCA
CITAZIONE (The Ancient One @ 9 Nov 2007, 15:21) *
La soluzione 2.0 di Thurlik si preannuncia moooolto interessante! roargh.gif


Ehmmm Thurlik, Ancient, per favore provate a caricare il mio save postato in precedenza e cercare il magazzino?
Thurlik
CITAZIONE (ILLOCA @ 12 Nov 2007, 11:47) *
Ehmmm Thurlik, Ancient, per favore provate a caricare il mio save postato in precedenza e cercare il magazzino?

Illoca, io ho provato a caricare le tue partite salvate, ma mi si chiude Exult quando lo faccio. Probabilmente tu usi una versione diversa dalla mia, oppure, contrariamente a me, hai qualche MOD installato. Io sto usando l'ultimissima snapshot di Exult, v1.4.03, quella del 6 novembre 2007.
Se può essere utile, magari posta qualche screenshot. I tasti predefiniti per salvare la schermata di Exult (in formato .pcx, e nella cartella di installazione di Exult) sono CTRL+ALT+s.
Comunque, cosa intendi con cercare il magazzino? Non appare nella mappa? È svanito come il ponte levatoio? Se è così non puoi far altro che giocare a partire da un savegame in cui sono ancora presenti gli elementi della mappa che ora non trovi.
The Ancient One
Domani provo con più calma.

Se ti è sparito anche quello, allora c'è veramente qualche problema strano.

Ti faccio sapere!
ILLOCA
CITAZIONE (Thurlik @ 12 Nov 2007, 15:52) *
Comunque, cosa intendi con cercare il magazzino? Non appare nella mappa? È svanito come il ponte levatoio? Se è così non puoi far altro che giocare a partire da un savegame in cui sono ancora presenti gli elementi della mappa che ora non trovi.


Eh gia' purtroppo non c'è nè il barile con dietro la leva, nè il comodino con dentro la chiave....
Da un lato sono contento che il mio orgoglio da giocatore ne esce "immacolato come colombo", dall'altro sale un po' la preoccupazione...
Vabbbhè tanto non mi interessavano i magazzini di LB, spero pero' che quando trovero' il tappeto volante di poter risolvere problemi come questi.


Comunque indipendentemente dai problemi di mancanze di oggetti, sono 2 giorni che exult mi butta fuori continuamente dopo 5 minuti di gioco, si blocca in momenti cardine come il momento del salvataggio e spesso viene fuori il pop up della memoria virtuale insufficiente...
Mi sembra molto strano.........
Avete consigli?
The Ancient One
CITAZIONE (ILLOCA @ 13 Nov 2007, 09:01) *
CITAZIONE (Thurlik @ 12 Nov 2007, 15:52) *
Comunque, cosa intendi con cercare il magazzino? Non appare nella mappa? È svanito come il ponte levatoio? Se è così non puoi far altro che giocare a partire da un savegame in cui sono ancora presenti gli elementi della mappa che ora non trovi.
Eh gia' purtroppo non c'è nè il barile con dietro la leva, nè il comodino con dentro la chiave....
Da un lato sono contento che il mio orgoglio da giocatore ne esce "immacolato come colombo", dall'altro sale un po' la preoccupazione...

Questo è veramente un mistero...
E' successo qualcosa che ha corrotto la tua mappa di gioco e non riesco proprio ad immaginare che cosa sia.
La mappa di gioco può essere modificata in tre modi:
- Con Exult Studio da un modder,
- Tramite le azioni del giocatore, se tale modifica è prevista dal codice del gioco o da un mod
- oppure cancellando gli oggetti dentro il gioco con CTRL+D
Ma presumo che nessuna di queste tre cose siano applicabili al tuo caso.

Sembra a tutti gli effetti un bug, anche perché giocando con i tuoi primi salvataggi quegli oggetti ci sono.
E' successo qualcosa nel mezzo...

Purtroppo le modifiche alla mappa vengono salvate nei savegame.
Questo significa che ristallando tutto, se utilizzi i tuoi salvataggi attuali, il problema esisterà ancora...

Non vedo una soluzione che ti permetta di far riapparire quegli oggetti. Se non, ovviamente, installare tutto da capo ed iniziare una nuova partita da zero.
E, a questo punto, spero veramente per te che il problema sia isolato.


CITAZIONE
Vabbbhè tanto non mi interessavano i magazzini di LB, spero pero' che quando trovero' il tappeto volante di poter risolvere problemi come questi.

Ti ho parlato del tappeto volante perché quello ti permetterebbe di atterrare sul tetto, utilizzando un metodo legale.
Ovviamente, trattandosi di un bug, è inutile ricorrere a metodi "legali" per risolverlo.
Tanto vale che tu usi il cheat.
Se ti manca la leva per accedere al tetto del castello, tanto vale che tu "apra" un muro con CTRL+D (scancellandolo fisicamente dalla mappa).



CITAZIONE
Comunque indipendentemente dai problemi di mancanze di oggetti, sono 2 giorni che exult mi butta fuori continuamente dopo 5 minuti di gioco, si blocca in momenti cardine come il momento del salvataggio e spesso viene fuori il pop up della memoria virtuale insufficiente...
Mi sembra molto strano.........
Avete consigli?

Effettivamente è strano.

Se ti viene un pop up di windows, però il problema è probabilmente di Windows.
Ma tu che computer hai?

Comunque, perché possiamo aiutarti, dovresti riportare qui i file stderr.txt e stdout.txt (o qualcosa di simile) che trovi nella cartella di exult.
Sono i log degli errori di exult.
Leggendo quelli si spera di poter capire da cosa dipendono i tuoi crash.

Un saluto!
-diego
ILLOCA
"credo" di aver capito il motivo per cui mi mandava al desktop ogni 30 secondi... rolleyes.gif
Avevo 0 Kb liberi su HD a causa della moglie che mi ha inzozzato il pc con le sue caxxo di puntate di smalville............. 25.gif
ILLOCA
CITAZIONE (The Ancient One @ 13 Nov 2007, 12:04) *
Comunque, perché possiamo aiutarti, dovresti riportare qui i file stderr.txt e stdout.txt (o qualcosa di simile) che trovi nella cartella di exult.
Sono i log degli errori di exult.
Leggendo quelli si spera di poter capire da cosa dipendono i tuoi crash.


Cavolo pensavo di aver trovato il problema e invece i crash continuano.
Appena inizio riesco a giocare 5 minuti e nei tentativi successivi a volte mi si blocca praticamente subito.

Mi da' questi errori con 2 pop up:

Runtime error
Program: D:ultima\exult.exe
This aplicationhas requested the runtime to terminate it in an unusual way

memoria virtuale del sistema insufficiente
Windows sta aumentando le dimensioni del file di paging.
Le richieste di memoria x alcune applicazioni potrebbero essere negate.

Vi allego i file citati
HELP !!!
The Ancient One
Aspettiamo di sentire cosa dice DK, però non sembra un problema legato a Exult.
Sembra un problema con il tuo computer.

Ma che impostazioni di memoria virtuale hai?
ILLOCA
CITAZIONE (The Ancient One @ 16 Nov 2007, 12:07) *
Ma che impostazioni di memoria virtuale hai?


Non so come si guardano, comunque qualcosa è successo visto che prima giocavo anche per 3 ore di fila e a un tratto questi problemi
The Ancient One
CITAZIONE (ILLOCA @ 16 Nov 2007, 14:07) *
CITAZIONE (The Ancient One @ 16 Nov 2007, 12:07) *
Ma che impostazioni di memoria virtuale hai?

Non so come si guardano, comunque qualcosa è successo visto che prima giocavo anche per 3 ore di fila e a un tratto questi problemi

Ora chiamo il super Toe (il tecnico di OGI), che magari ci illumina al riguardo.
Tu che PC hai?

Comunque dei problemi sul tuo computer spiegherebbe anche la sparizione di oggetti come il pontelevatoio.
Evidentemente c'è un qualche problema di corruzione dei salvataggi.
Infatti, controllando anche a fondo il forum e il bugtraker di exult nessun altro sembra aver riscontrato i tuoi problemi...

Vediamo cosa dice il toe!
Toelupe
wave.gif

Ho avuto lo stesso problema con Exult su un pc in test, risolto reimpostando la memoria virtuale; prova a far ricreare a windows il file di paging, probabile che si sia rovinato,
  • Vai in pannello di controllo -> sistema -> avanzate
  • clicca su impostazioni del riquadro prestazioni
  • Ora su avanzate e poi cambia
  • Seleziona la voce nessun file di paging, clicca su imposta, poi su ok
  • Riavvia il pc, così Windows cancellerà il file di paging
  • Fai uno scandisk e una bella deframmentazione
  • Riattiva la funzione (dimensione gestita dal sistema)
  • Riavvia il pc e vedi se và
Se non và ci si rivede dell'area tecnica biggrin.gif
The Ancient One
Tralascio di commentare la strepitosa rapidità di risposta...

CITAZIONE (Toelupe @ 16 Nov 2007, 15:59) *
Ho avuto lo stesso problema con Exult su un pc in test, risolto reimpostando la memoria virtuale; prova a far ricreare a windows il file di paging, probabile che si sia rovinato,[list]

shocked.gif
Il toe ha già perfino avuto modo di sperimentare il problema... shocked.gif shocked.gif


n5.gif
ILLOCA
CITAZIONE (Toelupe @ 16 Nov 2007, 15:59) *
Se non và ci si rivede dell'area tecnica biggrin.gif


No, no, se non và ci si rivede di persona...
Sono anche io di Milano biggrin.gif

P.s. cerco persone per il cartaceo la domenica sera, hai voglia?
ILLOCA
Smacchinando un po' con le impostazioni della memoria virtuale, all'inizio mi crashava lo stesso, ora una volta ogni mezz'ora, non è il massimo ma accettabile.
Speriamo continui su questo standard.
THX
DK
Allora, dai log vedo che stai giocando col keyring.

** nota tecnica **
AIDX è un opcode, un'istruzione che serve a prendere un elemento dallo stack. L'errore "Negative array index" indica che l'elemento da prendere è negativo (non esiste un indice negativo di un array).
E nella documentazione c'è scritto "NOTE: This opcode has been changed... need to redocument. "
** fine nota **

Quindi, forse il problema è dovuto all'utilizzo di una versione vecchia di Keyring o di Exult, o di entrambe.
Il mio consiglio è di provare ad aggiornare e vedere come si comporta.
Facci sapere.
ILLOCA
CITAZIONE (DK @ 19 Nov 2007, 21:47) *
Quindi, forse il problema è dovuto all'utilizzo di una versione vecchia di Keyring o di Exult, o di entrambe.
Il mio consiglio è di provare ad aggiornare e vedere come si comporta.
Facci sapere.


Il problema persiste anche se ora crasha ogni 10 minuti.
Onestamente non ho voglia di reinstallare una nuova versione con il dubbio dell'incompatibilita' dei save, inoltre mi sembra strano che prima andava e solo recentemente crasha frequentemente...
Continuero' per questa strada sperando di non rompermi i maroni... icon_salut.gif
Questa è la versione 'lo-fi' del forum. Per visualizzare la versione completa con molte più informazioni, formattazione ed immagini, per favore clicca qui.
Invision Power Board © 2001-2019 Invision Power Services, Inc.